|  首頁
說明

GoDaddy 說明

噠啦噠啦噠...計算中...計算中...啟動序列 42...
啵啵嗶嗶啵… 機器人自動化中… 此網頁是經由機器人自動翻譯成您的本地語言。某些翻譯可能還不盡完善,我們需要您的幫助!使用頁面底部的按鈕告訴我們本文是否有幫助。 前往英語版本

更新您的 Linux 核心 (CentOS 5 個)

如果您 CentOS 5 的伺服器已佈建 12 月 17 2010年前,您可能不執行的最新的 CentOS 核心,並且遺失許多重要安全補丁程式更新。

為什麼我錯過安全補丁程式更新?

您的 RAID 卡片提供必要的驅動程式,我們會用來在您的伺服器上安裝自訂的核心。不過,目前核心更新無法移除硬碟存取。

修正此問題,我們建議重新佈建您的伺服器。這會安裝已為您的 RAID 卡,以及所有必要的安全性更新驅動程式更新的核心。如需詳細資訊,請參閱我的伺服器 (重新佈建) 重新開始.

但是,如果您不想人金鑰您的伺服器,您可以手動更新您的核心並安裝 RAID 卡片驅動程式ElRepo.

向您發出警告:完成這些步驟需要深入 Linux 知識,進階程序。如果您決定要嘗試此程序,我們建議備份您的伺服器,並重新佈建,如果您無法順利完成這些步驟。

若要升級您的 CentOS 伺服器核心

  1. 透過 SSH,請登入您的伺服器為 '根目錄。'請參閱切換至根使用者在您的 Linux 伺服器資訊。
  2. 請確認您擁有的自訂的核心。類型:
    uname -r
    您應該會收到下列回應:
    2.6.18-HPTraid
    如果您收到不同的回應,您不使用自訂核心,並已使用更新的核心。
  3. 驗證您所預期的 RAID 卡片連線。類型:
    lspci -d 1103:1720
    您應該會收到下列回應:
    03:09.0 SCSI storage controller: HighPoint (or Triones) Technologies, Inc. RocketRAID
    1720 (2x SATA II RAID Controller) (rev 02)
    如果您收到另一個回應,請勿處理。
  4. 下載並安裝您的 RAID 卡的驅動程式。輸入以下命令:
    rpm --import http://elrepo.org/RPM-GPG-KEY-elrepo.org
    rpm -Uvh http://elrepo.org/elrepo-release-5-1.el5.elrepo.noarch.rpm
    yum --enablerepo=elrepo install kmod-rr172x
  5. 修改的檔案屬性您grub.conf檔案以進行編輯:
    chattr -i /boot/grub/grub.conf
  6. 修改您對 repo 檔案以允許核心更新註解中排除行出您CentOS-Base.repo檔案。類型:
    sed -i 's/^exclude/#exclude/' /etc/yum.repos.d/CentOS-Base.repo
  7. 安裝最新的核心。類型:
    yum update

    請注意:如果您並未看到核心安裝,再使用yum clean.

  8. 重新啟動您的伺服器。類型:
    reboot
  9. 請確認您安裝新的核心:
    uname -r
    您應該會收到下列回應:
    2.6.18-194.26.1.el5

這篇文章有用嗎?
感謝您提供意見。 若要與客戶服務代表聯絡,請撥打支援中心電話號碼,或使用上方的對話選項。
很高興能幫上忙! 還有什麼可幫您的嗎?
很抱歉有這種情形。 請告訴我們您不了解的部分,或解決方案無法解決您問題的原因。